...
 
Commits (5)
......@@ -61,7 +61,7 @@ Install base dependencies:
Requirements:
- Ansible >= 2.4.3.0
- Ansible >= 2.4.3.0, 2.8.x and above is not currently supported for OCP installations
- Jinja >= 2.7
- pyOpenSSL
- python-lxml
......
......@@ -9,7 +9,7 @@
%global __requires_exclude ^/usr/bin/ansible-playbook$
Name: openshift-ansible
Version: 3.9.81
Version: 3.9.82
Release: 1%{?dist}
Summary: Openshift and Atomic Enterprise Ansible
License: ASL 2.0
......@@ -203,6 +203,14 @@ Atomic OpenShift Utilities includes
%changelog
* Sat Jun 08 2019 AOS Automation Release Team <aos-team-art@redhat.com> 3.9.82-1
- allow cluster autoscaler to evict pods (jchaloup@redhat.com)
- Fail on Ansible 2.8 (rteague@redhat.com)
- Workaround missing network metrics when using cri-o (jcallen@redhat.com)
- Add a condition not to add "compute" label badly when master scaleup.yml
(bysnupy@hotmail.com)
- Remove bash debug flag from 99-origin-dns.sh script (rteague@redhat.com)
* Sat May 04 2019 AOS Automation Release Team <aos-team-art@redhat.com> 3.9.81-1
-
......
......@@ -22,7 +22,7 @@ def display(*args, **kwargs):
# Set to minimum required Ansible version
REQUIRED_VERSION = '2.4.3.0'
DESCRIPTION = "Supported versions: %s or newer" % REQUIRED_VERSION
DESCRIPTION = "Supported versions: %s or newer but less than 2.8.0" % REQUIRED_VERSION
class CallbackModule(CallbackBase):
......@@ -40,7 +40,7 @@ class CallbackModule(CallbackBase):
"""
super(CallbackModule, self).__init__()
if not parse_version(__version__) >= parse_version(REQUIRED_VERSION):
if not parse_version(REQUIRED_VERSION) <= parse_version(__version__) < parse_version('2.8.0'):
display(
'FATAL: Current Ansible version (%s) is not supported. %s'
% (__version__, DESCRIPTION), color='red')
......
......@@ -39,3 +39,11 @@ rules:
- list
- watch
attributeRestrictions: null
- apiGroups:
- ""
resources:
- "pods/eviction"
verbs:
- "create"
attributeRestrictions: null