...
 
Commits (6)
......@@ -61,7 +61,7 @@ Install base dependencies:
Requirements:
- Ansible >= 2.4.3.0, 2.5.x is not currently supported for OCP installations
- Ansible >= 2.4.3.0, 2.8.x and above is not currently supported for OCP installations
- Jinja >= 2.7
- pyOpenSSL
- python-lxml
......
......@@ -9,7 +9,7 @@
%global __requires_exclude ^/usr/bin/ansible-playbook$
Name: openshift-ansible
Version: 3.10.147
Version: 3.10.149
Release: 1%{?dist}
Summary: Openshift and Atomic Enterprise Ansible
License: ASL 2.0
......@@ -182,6 +182,13 @@ BuildArch: noarch
%{_datadir}/ansible/%{name}/test
%changelog
* Mon Jun 10 2019 AOS Automation Release Team <aos-team-art@redhat.com> 3.10.149-1
- allow cluster autoscaler to evict pods (jchaloup@redhat.com)
- Fail on Ansible 2.8 (rteague@redhat.com)
* Fri Jun 07 2019 AOS Automation Release Team <aos-team-art@redhat.com> 3.10.148-1
-
* Wed Jun 05 2019 AOS Automation Release Team <aos-team-art@redhat.com> 3.10.147-1
- Include dedicated etcd in upgrade if they are nodes (rteague@redhat.com)
- Workaround missing network metrics when using cri-o (jcallen@redhat.com)
......
......@@ -22,7 +22,7 @@ def display(*args, **kwargs):
# Set to minimum required Ansible version
REQUIRED_VERSION = '2.4.3.0'
DESCRIPTION = "Supported versions: %s or newer" % REQUIRED_VERSION
DESCRIPTION = "Supported versions: %s or newer but less than 2.8.0" % REQUIRED_VERSION
class CallbackModule(CallbackBase):
......@@ -40,7 +40,7 @@ class CallbackModule(CallbackBase):
"""
super(CallbackModule, self).__init__()
if not parse_version(__version__) >= parse_version(REQUIRED_VERSION):
if not parse_version(REQUIRED_VERSION) <= parse_version(__version__) < parse_version('2.8.0'):
display(
'FATAL: Current Ansible version (%s) is not supported. %s'
% (__version__, DESCRIPTION), color='red')
......
......@@ -39,3 +39,11 @@ rules:
- list
- watch
attributeRestrictions: null
- apiGroups:
- ""
resources:
- "pods/eviction"
verbs:
- "create"
attributeRestrictions: null